Missing all plugins after upgrading to v1.3.15

General support for problems installing or using Deluge
User avatar
hrip6
Member
Member
Posts: 10
Joined: Fri Jun 16, 2017 1:39 pm
OS or Distro: Debian

Missing all plugins after upgrading to v1.3.15

Postby hrip6 » Fri Jun 16, 2017 1:50 pm

Hi all,

Last Monday, I have upgraded my Deluge 1.3.10 to 1.3.15-dev by cloning the Git and use setup.py install --install-layout=deb after setup.py clean -a the environment, it's now working fine. However, all the default plugins is missing. I don't know how to get it back cause I need to use the plugin Scheduler to limit the bandwidth in peak time.

Code: Select all

root@bananapi:~# uname -a
Linux bananapi 3.4.113-sun7i #23 SMP PREEMPT Wed Jun 14 23:57:45 CEST 2017 armv7l GNU/Linux


Thanks for any advice. Kind regards. ;)

Here some of the image show the problem (version running, webui screen, thinclient screen), the plugin LabelPlus I have installed by .egg file:

deluge-2.PNG
deluge-2.PNG (9.54 KiB) Viewed 1597 times

deluge-1.PNG
deluge-1.PNG (22.78 KiB) Viewed 1597 times

deluge-3.PNG
deluge-3.PNG (22.24 KiB) Viewed 1597 times
Image Patreon: http://patreon.com/deluge_cas
Image Contact me: http://forum.deluge-torrent.org/ucp.php?i=pm&mode=compose&u=129152

shamael
Super Seeder
Super Seeder
Posts: 297
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Missing all plugins after upgrading to v1.3.15

Postby shamael » Mon Jun 19, 2017 12:16 pm

hi,

enabling the log will tell maybe the story (up to debug level if needed). Are you sure the same profile location is used? (where the plugins reside)
Maybe another profile is in use, similar to a reset then.

Cas
Top Bloke
Top Bloke
Posts: 3466
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Missing all plugins after upgrading to v1.3.15

Postby Cas » Tue Jun 20, 2017 4:19 pm

I don't know how you could have ended up with no plugins but it suggests an installation issue. Were there any issues when building deluge?

User avatar
hrip6
Member
Member
Posts: 10
Joined: Fri Jun 16, 2017 1:39 pm
OS or Distro: Debian

Re: Missing all plugins after upgrading to v1.3.15

Postby hrip6 » Thu Jun 22, 2017 9:02 am

shamael wrote:hi,

enabling the log will tell maybe the story (up to debug level if needed). Are you sure the same profile location is used? (where the plugins reside)
Maybe another profile is in use, similar to a reset then.


Hi, I'm creating the log file now, will be available soon it is available here. All the current torrents, settings are saved after I upgrade the Deluge. So I think it should be in the same profile location.

Cas wrote:I don't know how you could have ended up with no plugins but it suggests an installation issue. Were there any issues when building deluge?


I have no idea too. At first, year ago, I installed Deluge with apt-get install deluged deluge-web -y and they're fine. Until week ago I was browsing and see the Deluge has been updated to 1.3.15, then I thought mine (1.3.10) was too out-dated. So I decided to do an upgrading. Everything work fine, build with no error, nothing interrupt the installation process. And when I see my network traffic unusual, I check the plugins and find out the problem.I will upload the .log file soon.

Thanks @Cas and @shamael for your helps.

Update: this is the .log file I just create a min ago: http://sprunge.us/HdEZ
Image Patreon: http://patreon.com/deluge_cas
Image Contact me: http://forum.deluge-torrent.org/ucp.php?i=pm&mode=compose&u=129152

Cas
Top Bloke
Top Bloke
Posts: 3466
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Missing all plugins after upgrading to v1.3.15

Postby Cas » Thu Jun 22, 2017 10:45 am

You will need to provide the build and install log.

Have you tried deleting deluge and installing again?

User avatar
hrip6
Member
Member
Posts: 10
Joined: Fri Jun 16, 2017 1:39 pm
OS or Distro: Debian

Re: Missing all plugins after upgrading to v1.3.15

Postby hrip6 » Fri Jun 23, 2017 1:12 pm

Cas wrote:You will need to provide the build and install log.

Have you tried deleting deluge and installing again?

I have it installed and built already, where may I get the log? I also would like to learn where did I made mistake so I don't intend to delete and reinstall it :?
I also have run find / -name "*.egg", it results something like this:

Code: Select all

/usr/lib/python2.7/dist-packages/deluge-1.3.15_dev-py2.7.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Blocklist-1.3.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/AutoAdd-1.04.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Scheduler-0.2.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/WebUi-0.1.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Execute-1.3.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Extractor-0.4.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Notifications-0.2.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Label-0.2.egg
/root/deluge/dist/deluge-1.3.15_dev-py2.7.egg
/root/deluge/setuptools-0.6c11-py2.7.egg
/root/.config/deluge/plugins/LabelPlus-0.3.2.2-py2.7.egg

Does it mean I have incorrect installed folder for 1.3.15-dev? Am I suppose to cd /usr/lib/python2.7/dist-packages/ and then clone the git source there? I have cloned the git source in /root/deluge. Thanks a lot.
Image Patreon: http://patreon.com/deluge_cas
Image Contact me: http://forum.deluge-torrent.org/ucp.php?i=pm&mode=compose&u=129152

Cas
Top Bloke
Top Bloke
Posts: 3466
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Missing all plugins after upgrading to v1.3.15

Postby Cas » Fri Jun 23, 2017 3:10 pm

You plugin versions don't match 1.3.15. e.g. AutoAdd-1.04.egg is now 1.05.

What is the timestamp of these directories:

Code: Select all

/usr/lib/python2.7/dist-packages/deluge-1.3.15_dev-py2.7.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Blocklist-1.3.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/AutoAdd-1.04.egg
...


I also would like to learn where did I made mistake so I don't intend to delete and reinstall it :?

If you can replicate then we know for sure there is an issue. Otherwise we remain in the dark without further info.

User avatar
hrip6
Member
Member
Posts: 10
Joined: Fri Jun 16, 2017 1:39 pm
OS or Distro: Debian

Re: Missing all plugins after upgrading to v1.3.15

Postby hrip6 » Sat Jun 24, 2017 7:00 am

Cas wrote:You plugin versions don't match 1.3.15. e.g. AutoAdd-1.04.egg is now 1.05.

What is the timestamp of these directories:

Code: Select all

/usr/lib/python2.7/dist-packages/deluge-1.3.15_dev-py2.7.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/Blocklist-1.3.egg
/usr/lib/python2.7/dist-packages/deluge/plugins/AutoAdd-1.04.egg
...

I checked with WinSCP (as I don't know how to get timestamp from command):

Code: Select all

/usr/lib/python2.7/dist-packages/deluge-1.3.15_dev-py2.7.egg # 15/06/2017 11:25:31PM
/usr/lib/python2.7/dist-packages/deluge/plugins/Blocklist-1.3.egg # 09/03/2017 1:03:23AM
/usr/lib/python2.7/dist-packages/deluge/plugins/AutoAdd-1.04.egg # 09/03/2017 1:03:23AM
...
Image Patreon: http://patreon.com/deluge_cas
Image Contact me: http://forum.deluge-torrent.org/ucp.php?i=pm&mode=compose&u=129152


Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests