Torrents keep showing up as Error

General support for problems installing or using Deluge
Tvich
Member
Member
Posts: 33
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Torrents keep showing up as Error

Postby Tvich » Wed May 31, 2017 8:52 am

Also check the time on both guests, different timezones maybe?

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Wed May 31, 2017 6:34 pm

Tvich : I installed deluge from the standard repository and my libtorrent version is 1.0.11.0 .

Shamael : Tried adding the mount requirements to the unit file and I am still getting the same results.

I have not been able to find any samba problems and as far as I can tell the storage is running fine. I am going to try NFS to see if it helps. Never configured my own before so I am using the guide on unbuntu's web site. Got the drive mounted and torrents are being transferred. Will see how it goes.

Tvich
Member
Member
Posts: 33
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Torrents keep showing up as Error

Postby Tvich » Wed May 31, 2017 8:39 pm

Do:

Code: Select all

sudo add-apt-repository ppa:deluge-team/ppa

Code: Select all

apt update && apt upgrade


This should upgrade deluge from 1.3.12 to 1.3.15. Won't hurt and it's fast. Do it before anything else.

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Thu Jun 01, 2017 1:02 am

Did the upgrade and still no luck.

So far tried:

1) reviewed the samba logs on server -- nothing found
2) reviewed the samba configuration on server -- nothing found
3) reviewed the mount configuration on the client -- nothing found
4) reviewed the performance stats for the disks in the raid5 setup. -- disks had minimal latency stats
5) reconfigured the unit file to require mounted disk. -- tested and deluged won't start when the mount is missing
6) installed and configured NFS server/client and mounted nfs mount point to client. -- mounted and can r/w
7) updated repository and upgraded to the latest version

I have a feeling it has to do with the disk and going to go in that direction now. I went onto the nas machine and started copying 4gb+ files around. When the files were being copied the downloads would drop to 0 MiB/s and as soon as the copy finished it would jump back up to 10 MiB/s. Really hoping the disk configuration isn't the issue. Have about 8tb of files I'd have to find a temporary home for to fix.

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Wed Jun 14, 2017 3:12 pm

Ended up installing FreeNAS 9.10. It uses FreeBSD so I was able to load up the bhyve hyper-visor and install the deluge server on the freeNAS on an Ubuntu server. Since the rebuild I have been able to run deluge server without any errors for a couple days and the NAS has been completely stable.

My best guess at this point is storage was not stable but I couldn't find any logs to indicate what the issue was. I assume it was my configuration of the RAID5 disk using mdadm. Professionally I have always used hardware RAID cards so mdadm is something I don't have a lot of experience with.

Anyone looking for an all in one solution freeNAS is working for me. The bhyve hyper-visor was simple to setup with guides online. The VMs should be installed on SSD when using the hypervisor or the performance will be poor. The freeNAS has a nice web front end that makes it easy to setup the storage. Bhyve does not have a web interface but anyone familiar with the command prompt should be able to get it working. Having worked with VMWare for 10 years the bhyve configuration was very simple in comparison.

Tvich
Member
Member
Posts: 33
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Torrents keep showing up as Error

Postby Tvich » Thu Jun 15, 2017 10:34 am

Glad you got it working, don't forget to look into zfs snapshots for important (not multimedia data) and use docker for plex and deluge and sonar and nginx and etc.
Use the ssd for l2arc, if you don't need bhyve anymore.
glhf

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Thu Jun 15, 2017 6:27 pm

The only way I can think to free up the SSD would be to move the VM to the SATA storage or to move the installation of deluge to the freebsd freenas os running on a mini-ssd. Not sure how that would react to the freenas updates so I hesitate to build it that way. I might have tried the torrent client that comes as part of freenas but I have written a few python scripts that interact with plex to determine what I have and then searches the web for new episodes as they become available to auto add to deluge using the console.

I have setup the plex in a jail using the template that comes with freenas. I am probably going to learn how to setup a jail and then setup one for deluge and see if I can get it working.


Return to “Support”

Who is online

Users browsing this forum: Bing [Bot] and 8 guests