Torrents keep showing up as Error

General support for problems installing or using Deluge
paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Torrents keep showing up as Error

Postby paulto » Mon May 29, 2017 5:32 pm

Didn't see a linux install support forum so I hope it's ok to post this here.

I am looking into the cause but was hoping someone else might have had a similar issue and save me the time. I have an Ubuntu VM setup running deluge with a mounted samba share (also an Ubuntu VM running mdadm created raid5 disk using samba) as it's incoming and move to paths. Don't know if that is related yet but thought I'd throw it out there.

Daily some of my torrents are going into Error state and when I hit the resume action they resume with no issues. There is nothing I can determine about the affect torrents that is different from the others. I am currently seeding 70+ torrents and randomly 5-6 through out the day will go into error. The same will happen when I am only serving a couple torrents. I have never seen it where all the torrents are errored.

One thing I have noticed is that when I move large files on my share it can cause other connections to pause for a sec while it completes the task. I had been running 4x2tb drives and didn't experience the pause but since I upgraded to 4x4tb drives it has been happening. I am assuming that the errors I am getting are caused by the pause and have considered moving from a mdadm and native samba installation to a purpose made open-source NAS software, I have heard freeNAS is a good one.

Tvich
Member
Member
Posts: 30
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Torrents keep showing up as Error

Postby Tvich » Mon May 29, 2017 6:47 pm

Are you running a storage pool inside your virtual machine? Is your array built inside a vm?

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Mon May 29, 2017 7:29 pm

The storage are disks added to the VMWare host, ESXi 6.0.0, and then added to the VM. Inside the "NAS" VM I see 4 disks that I used mdadm to join into a RAID5 disk. The RAID5 disk is mounted on my "NAS" ubuntu 16.04 LTS server and then using samba I share it to the network. The torrent server also 16.04 LTS mounts the share to itself and uses those folders to download and then move to another folder on the RAID5 after the download is complete. 3 machines mount the drives, 2 ubuntu and 1 windows 10.

Tvich
Member
Member
Posts: 30
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Torrents keep showing up as Error

Postby Tvich » Tue May 30, 2017 9:10 am

You want to run deluged with "-L debug" flag. If you have deluge starting when the guest comes up, you are probably starting deluged with systemd, so edit the systemd file or stop the running daemon and run

Code: Select all

deluged -c /path/to/config -l /path/to/log_file.log -L debug

You will probably see, that you have some issues with your storage. It could be samba, but most likely it's something with your setup.

What is the reasoning for using a hypervisor? What else are you running on this host? Can you nuke it?

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Tue May 30, 2017 5:39 pm

I have run the debug logging command and have the logs generating. It is producing a lot of info. Is there anything I should be looking for specifically? I am waiting for another torrent to go into error and then I'll look through the logs for anything related.

I am using the hypervisor to run multiple servers on the same host to save money. It is running a plex, deluge torrent box, linux NAS and linux vpn gateway. I have been running the system for a couple years now and not had any issues until this recent error issue. I have been running hypervisors professionally since version 4 in environments of 500+ windows and 200+ linux servers so I have a experience with monitoring the performance of vm hosts. I haven't seen anything to indicate the server is overwhelmed.

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Tue May 30, 2017 8:53 pm

Tested the performance to make sure by :

1) streaming to 3 devices using transcoded video
2) converting 5 hours of video on the local disk using the sync feature of plex
3) copied 400gb of files at 80-100mb/s to my windows machine over wifi
4) downloading just about every version of ubuntu and linux mint at the same time in deluge, just under 40 torrents

It has all be running for about 20 minutes so far without any trouble so I think it is safe to say the hardware can support the load.

Tvich
Member
Member
Posts: 30
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Torrents keep showing up as Error

Postby Tvich » Tue May 30, 2017 9:30 pm

I don't have any experience running serious storage from inside the guest. You clearly do :) Good luck though.

Freenas is kinda off the table for you, zfs has a soft prerequisite of bare metal access to disks (perhaps pci pass through might help?).
If you must, try to look into write cache, it will cause problems, if freenas is running as a guest
paulto wrote:I am looking into the cause but was hoping someone else might have had a similar issue and save me the time. I have an Ubuntu VM setup running deluge with a mounted samba share (also an Ubuntu VM running mdadm created raid5 disk using samba) as it's incoming and move to paths.

Try mounting with NFS instead of smb, so you can remove samba from the equation.
paulto wrote:Daily some of my torrents are going into Error state and when I hit the resume action they resume with no issues. There is nothing I can determine about the affect torrents that is different from the others. I am currently seeding 70+ torrents and randomly 5-6 through out the day will go into error. The same will happen when I am only serving a couple torrents. I have never seen it where all the torrents are errored.

This is why, I'm suggesting you look into storage, check samba logs, etc. Inside deluged log file, look for info and warn level messages. Either you have problems with samba, or storage.
paulto wrote:One thing I have noticed is that when I move large files on my share it can cause other connections to pause for a sec while it completes the task. I had been running 4x2tb drives and didn't experience the pause but since I upgraded to 4x4tb drives it has been happening. I am assuming that the errors I am getting are caused by the pause and have considered moving from a mdadm and native samba installation to a purpose made open-source NAS software, I have heard freeNAS is a good one.

This looks like something is going from memory to disk
Are you running your storage on zfs or btrfs (any cow fs will do this. when writing from ram to disk)?

Also i would not worry about performance, if esxi hardware requirements are met, you are fine for deluge and plex.

paulto
Member
Member
Posts: 11
Joined: Mon May 29, 2017 4:51 pm
OS or Distro: Ubuntu

Re: Torrents keep showing up as Error

Postby paulto » Wed May 31, 2017 5:01 am

It is actually just ext3. Didn't have any errors pop up today. Never happens when you are watching. I did restart deluged manually and after a few of the torrents went into error states. In the logs I found :

[ERROR ] 00:38:06 torrentmanager:1147 on_alert_fastresume_rejected: linuxmint-18-mate-32bit.iso fast resume rejected: mismatching file timestamp
[DEBUG ] 00:38:06 torrent:431 Torrent 1a546a9a9d9cdb42ba7ab92ebebe4d9a3b05d164 set from Checking to Error: 'Error: Problem with resume data: mismatching file timestamp'
[ERROR ] 00:38:06 torrentmanager:1147 on_alert_fastresume_rejected: linuxmint-18-kde-64bit.iso fast resume rejected: mismatching file size
[DEBUG ] 00:38:06 torrent:431 Torrent 9a4da4f3872f5805217a64c11882c432ab1105eb set from Checking to Error: 'Error: Missing or invalid torrent data!
'

I went through all the logs in /var/log/samba on the nas server and couldn't find any errors.

After a few minutes I went back and checked the deluged log and found

[ERROR ] 00:50:43 torrent:468 Restart deluge to clear this torrent error
[ERROR ] 00:50:43 torrent:468 Restart deluge to clear this torrent error
[ERROR ] 00:50:43 torrent:468 Restart deluge to clear this torrent error


Will look more into it tomorrow but have somewhere to start now.

Tvich
Member
Member
Posts: 30
Joined: Thu Apr 27, 2017 6:36 pm
OS or Distro: Linux/Alpine,Debian

Re: Torrents keep showing up as Error

Postby Tvich » Wed May 31, 2017 6:49 am

Did you install deluge from ppa? What is the libtorrent version?

shamael
Seeder
Seeder
Posts: 230
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Torrents keep showing up as Error

Postby shamael » Wed May 31, 2017 8:17 am

hi,

For the error after daemon restart (or reboot) check my post, maybe related http://forum.deluge-torrent.org/viewtopic.php?f=7&t=48629&hilit=mount#p225413


Return to “Support”

Who is online

Users browsing this forum: No registered users and 9 guests