Updates not working (for me)

General support for problems installing or using Deluge
ray5450
New User
New User
Posts: 5
Joined: Sun May 28, 2017 3:11 pm
OS or Distro: Windows 7

Updates not working (for me)

Postby ray5450 » Sun May 28, 2017 3:38 pm

I started using Deluge some time ago a version or 2 before 1.3.12, and at those times, had updated fine all the way to said version. I am fine with 1.3.12, and have no problems, but it seems to me, that it is usually recommended to always use the newest version of everything.

I know there have been a couple releases since 1.3.12 After receiving the notice of each new version after 1.3.12, when I install any new version (after 1.3.12) nothing will download. They just say queued indefinitely. Uploads run. If I uninstall, and reinstall 1.3.12, everything works again. I have had several laptops and OS during this time, all with the same result. Please, advise.

ray5450
New User
New User
Posts: 5
Joined: Sun May 28, 2017 3:11 pm
OS or Distro: Windows 7

Re: Updates not working (for me)

Postby ray5450 » Tue Jun 06, 2017 12:53 pm

Well, I guess I'll have to keep using the old one, then.

Cas
Top Bloke
Top Bloke
Posts: 3474
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Updates not working (for me)

Postby Cas » Tue Jun 06, 2017 2:24 pm

What python version of 1.3.12 are you using? If it's py26 and you moving to py27 I would suggest uninstall then deleting the Program Files/Deluge folder.

The only main difference is libtorrent version between recent Deluge versions. You can check the changelog to see if any of the updates and fixes would apply to you.

ray5450
New User
New User
Posts: 5
Joined: Sun May 28, 2017 3:11 pm
OS or Distro: Windows 7

Re: Updates not working (for me)

Postby ray5450 » Wed Jul 05, 2017 12:44 am

Is Python part of Deluge when it installs, ...or is it something separate?

Shryp
Super Seeder
Super Seeder
Posts: 407
Joined: Mon Apr 20, 2015 10:20 pm
OS or Distro: Windows 7, Manjaro

Re: Updates not working (for me)

Postby Shryp » Wed Jul 05, 2017 2:16 am

ray5450 wrote:Is Python part of Deluge when it installs, ...or is it something separate?


For with Windows versions python is built into the install exe file.

ray5450
New User
New User
Posts: 5
Joined: Sun May 28, 2017 3:11 pm
OS or Distro: Windows 7

Re: Updates not working (for me)

Postby ray5450 » Thu Jan 25, 2018 12:37 am

Sorry, I lost track of this thread, but I am still using the old version with no problem.

In the Program Files folder, it has "deluge-1.3.12-py2.6.egg". After uninstalling the old version, I have already tried deleting all Deluge folders everywhere, but it made no difference. I even tried the new version on a new install of Windows and it made no difference.

As far as checking the changelog, if I did find something that changed. I don't think there would be anything I could do about it, except use the old version.

shamael
Super Seeder
Super Seeder
Posts: 334
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updates not working (for me)

Postby shamael » Thu Jan 25, 2018 8:23 am

Weird, I have "deluge-1.3.15-py2.7.egg" in my folder. You said you made a new install of Windows and you still remain with an older version???
As long as the folder "c:\Program Files (x86)\Deluge\" is deleted and you download the last installer you should have 1.3.15 version, certainly with a new installation. Are you sure you use the correct install binary?

ray5450
New User
New User
Posts: 5
Joined: Sun May 28, 2017 3:11 pm
OS or Distro: Windows 7

Re: Updates not working (for me)

Postby ray5450 » Fri Jan 26, 2018 2:47 am

Sorry, I did not clarify.

"deluge-1.3.12-py2.6.egg" is in the folder of the old version that I am currently using. It does change to/with the new version after uninstalling and deleting folders, but like I said, nothing will download.

What I meant with a Windows install, is that after the Windows install, I have installed directly the new Deluge version with the same result.

shamael
Super Seeder
Super Seeder
Posts: 334
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Updates not working (for me)

Postby shamael » Fri Jan 26, 2018 9:27 am

Reviewing the setting of Deluge, are the path in preferences>download correct? Can you select and set them again just to confirm?
Another good test should be to create a new folder (anywhere) and select it as download path, keep the checkbox "move to" unticked.
What happen then?


Return to “Support”

Who is online

Users browsing this forum: No registered users and 7 guests