[SOLVED] Can not edit Preferences on 1.3.15

General support for problems installing or using Deluge
User avatar
gderf
Leecher
Leecher
Posts: 73
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

[SOLVED] Can not edit Preferences on 1.3.15

Postby gderf » Fri May 12, 2017 4:32 pm

Today I upgraded to 1.3.15-0~xenial~ppa1 on Linux Mint 18.1. I also upgraded my OMV 2 server (Debian Wheezy based) to 1.3.15-0~precise~ppa1.

On Mint, in the Deluge client, I click on Edit | Preferences or type Ctrl + P, but nothing is displayed.

If I start the program from a terminal and then try to display Preferences, I get this:

fred@telescope ~ $ deluge

(deluge:8802): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(deluge:8802): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(deluge:8802): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(deluge:8802): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(deluge:8802): libglade-WARNING **: unknown attribute `swapped' for <signal>.

Unhandled error in Deferred:


Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/twisted/protocols/policies.py", line 120, in dataReceived
self.wrappedProtocol.dataReceived(data)
File "/usr/lib/python2.7/dist-packages/deluge/ui/client.py", line 179, in dataReceived
d.callback(request[2])
File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 393, in callback
self._startRunCallbacks(result)
File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 501, in _startRunCallbacks
self._runCallbacks()
--- <exception caught here> ---
File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 588, in _runCallbacks
current.result = callback(current.result, *args, **kw)
File "/usr/lib/python2.7/dist-packages/deluge/ui/gtkui/preferences.py", line 221, in _on_get_cache_status
self._show()
File "/usr/lib/python2.7/dist-packages/deluge/ui/gtkui/preferences.py", line 323, in _show
lt_single_proxy = component.get("PreferencesManager").LT_SINGLE_PROXY
File "/usr/lib/python2.7/dist-packages/deluge/component.py", line 427, in get
return _ComponentRegistry.components[name]
exceptions.KeyError: 'PreferencesManager'
Last edited by gderf on Sat May 13, 2017 3:14 am, edited 1 time in total.

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can not edit Preferences on 1.3.15

Postby Cas » Fri May 12, 2017 5:19 pm

Oh hmm, how did that happen!

User avatar
gderf
Leecher
Leecher
Posts: 73
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Can not edit Preferences on 1.3.15

Postby gderf » Fri May 12, 2017 5:32 pm

Cas wrote:Oh hmm, how did that happen!


LOL. Beats me! I downgraded the client back to 1.3.14 but left the server upgraded to 1.3.15.

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can not edit Preferences on 1.3.15

Postby Cas » Fri May 12, 2017 6:01 pm


User avatar
gderf
Leecher
Leecher
Posts: 73
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Can not edit Preferences on 1.3.15

Postby gderf » Fri May 12, 2017 6:19 pm

That fixes it, thanks. I guess you will propagate new packages to all that have them?

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can not edit Preferences on 1.3.15

Postby Cas » Fri May 12, 2017 7:11 pm

Yeah I'll sort it all out...

User avatar
gderf
Leecher
Leecher
Posts: 73
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Can not edit Preferences on 1.3.15

Postby gderf » Fri May 12, 2017 7:18 pm

Thanks for the quick fix.

(The forum is running super slow today)

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can not edit Preferences on 1.3.15

Postby Cas » Fri May 12, 2017 10:15 pm

Well it was bound to be the new piece of code I put in... Updated the PPA and hopefully got the slow website sorted

Oh and thanks for reporting it so quickly, actually saved a lot of grief tomorrow. ;)

User avatar
gderf
Leecher
Leecher
Posts: 73
Joined: Sat Jun 18, 2016 1:32 am
OS or Distro: Debian Linux

Re: Can not edit Preferences on 1.3.15

Postby gderf » Fri May 12, 2017 10:43 pm

You're welcome. I got the PPA updates already. I guess most users missed the update to the broken packages.

Web site is snappy again too.

banjopotato
New User
New User
Posts: 5
Joined: Sun Jan 01, 2017 4:19 pm
OS or Distro: Ubuntu 14.04.5

Re: [SOLVED] Can not edit Preferences on 1.3.15

Postby banjopotato » Sun May 14, 2017 10:02 am

The Mac version linked to in the "Downloads" section is still the defective one.


Return to “Support”

Who is online

Users browsing this forum: Bing [Bot] and 12 guests