Problems setting up deluged and deluge-web

General support for any problems installing or running Deluge
feelfreetoblameme
Member
Member
Posts: 13
Joined: Tue May 06, 2014 8:23 pm
OS or Distro: Xubuntu 16.04

Problems setting up deluged and deluge-web

Postby feelfreetoblameme » Sat Mar 11, 2017 4:09 am

I'm probably missing something very obvious here but would appreciate any assistance. I've been running Deluge for a while on my Xubuntu 16.04 machine without problems but I probably didn't set it up right the first go around so now am paying a possible price. I had never set up deluge-web and I was running the deluged daemon on session startup as myself. Decided to do things right, and followed the wikis to create user and group "deluge", and created systemd services for deluged and deluge-web. Everything seems to be working just fine, I think, I'm still seeding and downloading without issues. The deluged service is now running under user deluge and my user account is in the deluged group. When I launch the WebUI, however, I can't autoconnect to the daemon and port that I had set up before. I realized after some research that WebUI and deluged are now running off of the "deluge" user and the GTK UI is running under my user account. Is this a problem? Should I copy my old web.conf and hostlist.conf to the deluge user config to get WebUI to autoconnect to the correct hostlist ID? Or is it the auth file that is important?

Thanks for any help, my apologies for being a bit lost! I certainly don't need the WebUI but it would be nice to get everything working as it should be.

shamael
Seeder
Seeder
Posts: 198
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Problems setting up deluged and deluge-web

Postby shamael » Sun Mar 12, 2017 11:59 am

have a look to my post, I think it may help http://forum.deluge-torrent.org/viewtopic.php?f=7&t=54430

Cas
Top Bloke
Top Bloke
Posts: 3349
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Problems setting up deluged and deluge-web

Postby Cas » Sun Mar 12, 2017 12:29 pm


feelfreetoblameme
Member
Member
Posts: 13
Joined: Tue May 06, 2014 8:23 pm
OS or Distro: Xubuntu 16.04

Re: Problems setting up deluged and deluge-web

Postby feelfreetoblameme » Mon Mar 13, 2017 12:17 am

Thank you both. Yes, I did see your post after I'd posted, shamael, and it did help. I got everything working, briefly, but realized I still had some kind of conflict with another daemon running. As is the way, instead of leaving well enough alone, I'm now contemplating reinstalling deluge and starting from scratch! I'm pretty sure I followed the wikis when I did my last clean install but somehow stuff got borked. Appreciate the assistance, I'm sure I'll be on here reading some more over the next few hours.

shamael
Seeder
Seeder
Posts: 198
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Problems setting up deluged and deluge-web

Postby shamael » Mon Mar 13, 2017 9:34 am

Maybe you started the daemon by running the command under your own user and in parallel launched the systemd setup?
Check the running processes (sudo ps aux|grep -i delug) can maybe help to figure it out

feelfreetoblameme
Member
Member
Posts: 13
Joined: Tue May 06, 2014 8:23 pm
OS or Distro: Xubuntu 16.04

Re: Problems setting up deluged and deluge-web

Postby feelfreetoblameme » Tue Mar 14, 2017 1:03 am

I think that is what happened. The systemd service seems to be conflicting with a process that runs under python. When I hover over the process, it's running in /usr/bin as it should but it's using my regular user's account as the config directory. I'm planning a rip and replace. Question: I want to keep my torrents for seeding purposes on my new installation. Should I copy the state folder into the newly created deluge user's config or my user's config? I don't necessarily plan on accessing deluge from outside my network but I'd like the webui to work and be running only one daemon at startup. Thank you for your help!

feelfreetoblameme
Member
Member
Posts: 13
Joined: Tue May 06, 2014 8:23 pm
OS or Distro: Xubuntu 16.04

Re: Problems setting up deluged and deluge-web

Postby feelfreetoblameme » Tue Mar 14, 2017 5:51 am

Okay, looks like we are back in business. Phew! I love Linux but sometimes with permissions and services it's just too much "fun"! Thanks for the help.

shamael
Seeder
Seeder
Posts: 198
Joined: Sat Oct 08, 2016 9:28 am
OS or Distro: osmc

Re: Problems setting up deluged and deluge-web

Postby shamael » Tue Mar 14, 2017 10:53 am

Deluge takes its config from the home folder of the user launching the server. It means different config file is started under your own user or if you start it through systemd http://dev.deluge-torrent.org/wiki/UserGuide/Service/systemd. If the systemd setup is made you have to control the server with systemctl command, so the proper config file is always used.

To keep your torrents seeding you simply have to copy the state folder in the profile of the daemon user so /var/lib/deluge/.config/deluge/state

You you copy file from another profile be sure to set the permissions for the user deluge (systemd setup).I had to recreate my profile multiple times these last days for another issue with a copy of the state file to not loose anything and simply used the command below to assume all permissions are well set

Code: Select all

sudo chown -R deluge:deluge /var/lib/deluge/.config/deluge/

feelfreetoblameme
Member
Member
Posts: 13
Joined: Tue May 06, 2014 8:23 pm
OS or Distro: Xubuntu 16.04

Re: Problems setting up deluged and deluge-web

Postby feelfreetoblameme » Wed Mar 15, 2017 5:25 am

Thanks very much for this very good point. My state files were from my user folder so I am guessing that is why I am having a hell of a time getting everything back up and running. In fact everything seemed fine and then my torrents started to get errors and then over the course of the day they all started to fail. I could have something really funky going on but I am going to try your suggestion of making sure my new state folder has the right permissions. I'll let you know how it goes!

feelfreetoblameme
Member
Member
Posts: 13
Joined: Tue May 06, 2014 8:23 pm
OS or Distro: Xubuntu 16.04

Re: Problems setting up deluged and deluge-web

Postby feelfreetoblameme » Wed Mar 15, 2017 5:30 am

Never mind! I just checked my trackers and they are all down. Looks like a big DDoS attack is ongoing. Phew, nothing to do with my setup after all then!


Return to “General Support”

Who is online

Users browsing this forum: No registered users and 2 guests