Can't upgrade libtorrent to 1.1.1

General support for problems installing or using Deluge
banjopotato
New User
New User
Posts: 5
Joined: Sun Jan 01, 2017 4:19 pm
OS or Distro: Ubuntu 14.04.5

Can't upgrade libtorrent to 1.1.1

Postby banjopotato » Sun Jan 01, 2017 4:29 pm

I'm running Deluge 1.3.13 under Ubuntu 14.04.5 with libtorrent-rasterbar 1.0.10.

I'd like to upgrade to 1.1.1 but configure fails with

Code: Select all

configure: error: Boost.Chrono library not found. Try using --with-boost-chrono=lib


When I try running it with the suggestion, it fails with this:

Code: Select all

configure: error: Could not link against boost_chrono-lib !


If I try this:

Code: Select all

sudo apt-get install build-essential checkinstall libboost-system-dev libboost-python-dev libssl-dev libgeoip-dev


I get:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
libgeoip-dev is already the newest version.
checkinstall is already the newest version.
libssl-dev is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-python-dev : Depends: libboost-python1.54-dev but it is not going to be installed
 libboost-system-dev : Depends: libboost-system1.54-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Code: Select all

dpkg --get-selections | grep hold


turns up nothing.

I've currently got libboost 1.55 installed so I'm not sure why I need to downgrade.

Any help resolving this much appreciated.

Return to “Support”

Who is online

Users browsing this forum: Yahoo [Bot] and 8 guests