Thin client disconnects

General support for problems installing or using Deluge
Bolfass
New User
New User
Posts: 1
Joined: Wed Nov 11, 2015 11:18 pm
OS or Distro: Ubuntu 14.04.3 LTS

Thin client disconnects

Postby Bolfass » Thu Nov 12, 2015 12:04 am

Client: 1.3.12
Server: 1.3.12
libtorrent: 0.16.17.0

I'm having troubles with disconnects from the daemon running on Ubuntu 14.04.03 LTS. I'm connecting with clients from two windows 10 machines and one windows 2012 R2.

Sometimes I get the line below in the log file. Sometimes it's just giving me the silent treatment about having just dropped my client connection and then hints about a non-clean disconnect when I log in again.

[INFO ] 21:37:34 rpcserver:224 Deluge client disconnected: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert bad record mac')]
[INFO ] 21:52:34 rpcserver:224 Deluge client disconnected: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert bad record mac')]
[INFO ] 00:07:34 rpcserver:224 Deluge client disconnected: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert bad record mac')]
[INFO ] 00:07:35 rpcserver:224 Deluge client disconnected: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert bad record mac')]
[INFO ] 00:37:33 rpcserver:224 Deluge client disconnected: [('SSL routines', 'SSL3_READ_BYTES', 'sslv3 alert bad record mac')]

Anyone aware of any solution or could point me in a general direction?

Regards

Shryp
Super Seeder
Super Seeder
Posts: 384
Joined: Mon Apr 20, 2015 10:20 pm
OS or Distro: Windows 7, Manjaro

Re: Thin client disconnects

Postby Shryp » Mon Nov 16, 2015 2:23 pm

Mine seems to disconnect about once a day or so. I have learned to just live with it. I haven't bothered looking for the logs on 1.3.12, but when I did on 1.3.11 I never saw that error message.

Using a Windows7 daemon and a Windows7/LinuxMint client.

gggirlgeek
Member
Member
Posts: 13
Joined: Mon Oct 10, 2016 11:59 pm
OS or Distro: Windows 7 x64

Re: Thin client disconnects

Postby gggirlgeek » Wed Oct 19, 2016 3:11 am

My client is doing this too. I'm using 1.13.13 on Win7x64, and another on Win7x86. It's rather annoying because it doesn't keep my column sort order when reconnecting. I have the thin client open 24-hours a day. Can someone please help us fix this?
Deluge v1.13
libtorrent v1.09.09
Seedbox: Debian 8.6
Client on: Win7x64

koolmon10
New User
New User
Posts: 2
Joined: Wed Oct 26, 2016 9:31 pm
OS or Distro: Win 2012r2/CentOS 7

Re: Thin client disconnects

Postby koolmon10 » Wed Oct 26, 2016 9:35 pm

Bump. Having this issue as well. Daemon with sporadically refuse connections from any source, including webui, multiple thin clients, and other utilities that connect to deluge. Noticed a similar error in my logs.
deluged: 1.3.12
libtorrent: 1.0.9.0

djhifi
New User
New User
Posts: 9
Joined: Wed Oct 11, 2017 6:12 pm
OS or Distro: Synology DSM 6.0

Re: Thin client disconnects

Postby djhifi » Wed Oct 11, 2017 6:16 pm

same issue in 2017 happening with me.

They really need to release another version...


Return to “Support”

Who is online

Users browsing this forum: No registered users and 14 guests