Permission Denied on Web UI Downloads

General support for any problems installing or running Deluge

Permission Denied on Web UI Downloads

Postby Samsicle » Fri May 17, 2013 12:49 am

Hi All

So I recently followed the guide at http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient to set up Web UI. I also follwed the instructions for creating an init script but stopped before the section on logging. I can download a file just fine through the web interface (I download to '/home/sam/Downloads') but when I actually go onto the computer running deluge I have no permission to '/home/sam/Downloads/filename'

I suspect it has something to do with the user i set up (deluge) and the file being in my home directory (sam). But clearly I dont know what I am doing.

If I run ls -lh under the downloads directory, the file shows it belongs to the user and group 'root'.

If anyone with a greater amout of knowledge than me has the solution it would be much appreciated.
Samsicle
New User
New User
 
Posts: 1
Joined: Fri May 17, 2013 12:31 am

Re: Permission Denied on Web UI Downloads

Postby absteeve » Wed Oct 30, 2013 6:43 am

where's the answer to this? You know... from back in May? Don't suppose there's much point in me asking the same thing just to get the same non-answer?
absteeve
New User
New User
 
Posts: 1
Joined: Wed Oct 30, 2013 6:39 am

Re: Permission Denied on Web UI Downloads

Postby crazycaveman » Wed Nov 13, 2013 4:19 pm

What is the output you get when you run `ls -l`? Just copy and paste it here. From what you describe, it sounds like the owner and group are root. If this is the case, it would seem that the deluge daemon is not running as the deluge user you created.

There are a couple of fixes/workarounds available to resolve this. One is to set the sticky-bit for the group on the directory the downloads are saved to. This will force all the files in that directory to be owned by the same group as the directory; you can do this by running `chmod g+s /home/sam/Downloads`. Another option is to change the gid for the deluge user to something sam has access to. In my setup, I have a downloads group that is the main group for deluge and a supplementary group for users I want to be able to access the downloads. The third option is to set umask to 0000 (`umask 0000`) as deluge before starting deluged; this can be done in the startup script you created (if you paste it here, I can help modify it).
crazycaveman
Member
Member
 
Posts: 28
Joined: Mon Apr 30, 2012 3:08 am


Return to Support

Who is online

Users browsing this forum: Bing [Bot] and 13 guests