Deluge 1.3.5 on Ubuntu 12.04 (precise)

General support for any problems installing or running Deluge

Re: Deluge 1.3.5 on Ubuntu 12.04 (precise)

Postby Cas » Sun Sep 02, 2012 7:59 am

How about just leave building from source for now and only install the official precise repository packages for deluge and libtorrent to see if those will work.
Cas
Developer
Developer
 
Posts: 2264
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Deluge 1.3.5 on Ubuntu 12.04 (precise)

Postby rtor » Sun Sep 02, 2012 1:17 pm

Both are the same. Is the official one in /usr/bin?

$ /usr/bin/deluged -v
deluged: 1.3.5
Segmentation fault (core dumped)


$ /usr/local/bin/deluged -v
deluged: 1.3.5-dev
Segmentation fault (core dumped)
rtor
New User
New User
 
Posts: 8
Joined: Wed Aug 29, 2012 11:52 am

Re: Deluge 1.3.5 on Ubuntu 12.04 (precise)

Postby Cas » Sun Sep 02, 2012 9:37 pm

A segfault is usually a libtorrent issue so what version of libtorrent and do you have a backtrace?
Cas
Developer
Developer
 
Posts: 2264
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Deluge 1.3.5 on Ubuntu 12.04 (precise)

Postby rtor » Mon Sep 03, 2012 1:48 pm

There are bunch of them.

Code: Select all
locate libtorrent | grep so | grep -v home
/usr/lib/libtorrent-rasterbar.so.6
/usr/lib/libtorrent-rasterbar.so.6.0.0
/usr/lib/libtorrent.so.14
/usr/lib/libtorrent.so.14.0.1
/usr/lib/debug/usr/lib/libtorrent-rasterbar.so.6.0.0
/usr/lib/debug/usr/lib/python2.7/dist-packages/libtorrent.so
/usr/lib/debug/usr/lib/python2.7/dist-packages/libtorrent_d.so
/usr/lib/pyshared/python2.7/libtorrent.so
/usr/lib/python2.7/dist-packages/libtorrent.so
/usr/local/include/libtorrent/broadcast_socket.hpp
/usr/local/include/libtorrent/socket.hpp
/usr/local/include/libtorrent/socket_type.hpp
/usr/local/include/libtorrent/socks5_stream.hpp
/usr/local/include/libtorrent/udp_socket.hpp
/usr/local/lib/libtorrent-rasterbar.so
/usr/local/lib/libtorrent-rasterbar.so.6
/usr/local/lib/libtorrent-rasterbar.so.6.0.0
/usr/local/lib/libtorrent.so
/usr/local/lib/libtorrent.so.11
/usr/local/lib/libtorrent.so.11.0.6
/usr/local/lib/python2.7/dist-packages/deluge-1.3.5-py2.7-linux-x86_64.egg/deluge/libtorrent.so
/usr/local/lib/python2.7/dist-packages/deluge-1.3.5_dev-py2.7-linux-x86_64.egg/deluge/libtorrent.so


Code: Select all
strace deluged -d
{...}
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/libstdc++.so.6", O_RDONLY|O_CLOEXEC) = 8
read(8, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0P\241\5\0\0\0\0\0"..., 832) = 832
fstat(8, {st_mode=S_IFREG|0644, st_size=962656, ...}) = 0
mmap(NULL, 3142544, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 8, 0) = 0x7f8a3ffcf000
mprotect(0x7f8a400b1000, 2093056, PROT_NONE) = 0
mmap(0x7f8a402b0000, 40960, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 8, 0xe1000) = 0x7f8a402b0000
mmap(0x7f8a402ba000, 82832, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f8a402ba000
close(8)                                = 0
mprotect(0x7f8a402b0000, 32768, PROT_READ) = 0
mprotect(0x7f8a404d1000, 4096, PROT_READ) = 0
mprotect(0x7f8a406e9000, 8192, PROT_READ) = 0
mprotect(0x7f8a40934000, 8192, PROT_READ) = 0
mprotect(0x7f8a40b54000, 4096, PROT_READ) = 0
brk(0x243c000)                          = 0x243c000
munmap(0x7f8a4425e000, 75005)           = 0
close(7)                                = 0
stat("/usr/local/lib/python2.7/dist-packages/deluge-1.3.5_dev-py2.7-linux-x86_64.egg/deluge/libtorrent", 0x7fffb1d09030) = -1 ENOENT (No such file or directory)
open("/usr/local/lib/python2.7/dist-packages/deluge-1.3.5_dev-py2.7-linux-x86_64.egg/deluge/libtorrent.so", O_RDONLY) = 7
fstat(7, {st_mode=S_IFREG|0755, st_size=62287732, ...}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV (core dumped) +++
rtor
New User
New User
 
Posts: 8
Joined: Wed Aug 29, 2012 11:52 am

Re: Deluge 1.3.5 on Ubuntu 12.04 (precise)

Postby Cas » Tue Sep 04, 2012 12:27 am

Please remove/purge all libtorrent packages and any remaining files. Then install libtorrent-rasterbar6 and python-libtorrent from the Precise apt repository.

There are two libtorrent libraries one is for rtorrent and the other is libtorrent-rasterbar which is used by Deluge and other torrent clients.
Cas
Developer
Developer
 
Posts: 2264
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: Deluge 1.3.5 on Ubuntu 12.04 (precise)

Postby rtor » Tue Sep 04, 2012 12:44 am

That eventually helped!
Obviosly it was some broken libtorrent libs.
I had to wipe all libtorrent* files manually, then installed packages as usual and it worked.

Thanks a lot for helping!
rtor
New User
New User
 
Posts: 8
Joined: Wed Aug 29, 2012 11:52 am

Previous

Return to Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests

cron