webui add torrent urls

General support for any problems installing or running Deluge

webui add torrent urls

Postby Bunta » Fri Mar 09, 2012 6:38 am

Hi there

I just wanted to know if deluge webui supports adding torrents via a url link.
For example something like http://localhost:8112/remote/torrent/ad ... me.torrent
It used to support formats like this with the /remote/torrent/add url but that doesn't seem to work any more.
Is there still another URL format that supports this type of action?
Bunta
New User
New User
 
Posts: 4
Joined: Fri Mar 09, 2012 6:33 am

Re: webui add torrent urls

Postby Bunta » Wed Mar 21, 2012 6:31 am

Anyone?

I need this functionality in order to enable magnet link support for deluge client in a webui firefox plugin I develop.
Bunta
New User
New User
 
Posts: 4
Joined: Fri Mar 09, 2012 6:33 am

Re: webui add torrent urls

Postby Cas » Wed Mar 21, 2012 1:35 pm

You need to use the json api and you can look at an existing greasemonkey script or any of the other browser plugins source code for hints on how to use it.
Cas
Developer
Developer
 
Posts: 2300
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: webui add torrent urls

Postby Bunta » Tue Apr 10, 2012 7:05 am

Thanks for that, I now have magnet link support working correctly in my addon:
https://addons.mozilla.org/en-US/firefo ... ui-120685/

Although it did take me quite a long time to realise that the magnet support was not working correctly as indicated with deluge 1.3.4.
I messed around altering my code a hundred times until I downloaded 1.3.5 and found it was working fine with my first version :P
Bunta
New User
New User
 
Posts: 4
Joined: Fri Mar 09, 2012 6:33 am

Re: webui add torrent urls

Postby Cas » Tue Apr 10, 2012 10:49 am

Nothing changed in 1.3.5 that should have affected that but good to know it works now. I've added a link to Plugins page.
Cas
Developer
Developer
 
Posts: 2300
Joined: Mon Dec 07, 2009 6:04 am
Location: Scotland

Re: webui add torrent urls

Postby Bunta » Wed Apr 11, 2012 6:22 am

Hmm thats strange, maybe there was just something wrong with the client I had installed.
Bunta
New User
New User
 
Posts: 4
Joined: Fri Mar 09, 2012 6:33 am


Return to Support

Who is online

Users browsing this forum: Bing [Bot] and 8 guests