AutoAdd link error

General support for any problems installing or running Deluge
enri
New User
New User
Posts: 7
Joined: Tue Feb 14, 2017 5:08 am
OS or Distro: docker

AutoAdd link error

Postby enri » Tue Feb 14, 2017 5:14 am

My system is Mac with Docker installed on NAS
I can add the magnet link 1 by 1 without problem.

Problem is, when I want to add multiple magnet link, I use AutoAdd. Save the link below as test.magnet in the watch folder. When they are alone only 1 line in each file, it can process without problem. When I add them in 1 file, error occurs: only 2 link in the task list, 1st line is all 0 include the hash. The 2nd line is error with comment unsupported URL protocol:

Sometimes it mentioned about Mac OS X com.apple.metadata in the same error.

I tried different encoding (UTF-8, Western Windows Latin 1) and different line format (Unix, Windows) and have no luck. Any idea why this happens?

Code: Select all

--removed--
Last edited by enri on Fri Feb 17, 2017 2:00 am, edited 1 time in total.

enri
New User
New User
Posts: 7
Joined: Tue Feb 14, 2017 5:08 am
OS or Distro: docker

Re: AutoAdd link error

Postby enri » Tue Feb 14, 2017 5:31 pm

I found that it behave the same on a new install of Mac version. I also use Windows to create the text file, also have the same error

I look at the log and found that it just state the error item as shown in the webui.

Is it a bug in the AutoAdd plugin?

Cas
Top Bloke
Top Bloke
Posts: 3294
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: AutoAdd link error

Postby Cas » Tue Feb 14, 2017 5:52 pm

You really need to provide the actual errors.

Having spaces between the items is a problem actually and perhaps the line ending is causing an issue.

enri
New User
New User
Posts: 7
Joined: Tue Feb 14, 2017 5:08 am
OS or Distro: docker

Re: AutoAdd link error

Postby enri » Wed Feb 15, 2017 6:04 am

Thanks for your reply. Below are the details:

File: test13.magnet - No empty line, no space after each line

Code: Select all

--removed--


The hash of them (obtained by adding them from GUI):
1st line: --
2nd line: --
3rd line: --

I put test13.magnet to the watch folder, and it process the file, return with this file
test13.magnet.1.magnet.invalid

Code: Select all

--removed--

This cannot be invalid because manually adding it is error-free

The GUI give me 2 items only. The detail of the 2 items are below:

Code: Select all

Name: 0000000000000000000000000000000000000000
Hash: 0000000000000000000000000000000000000000
Path: /downloads/Deluge
Total Size:
# of files: 0
Comment:
Status: OK
Tracker:

Name: [DMG][Rewrite][15][720P][BIG5].mp4
Hash: 28f47da2bd3ca0c033e7bac0793fe38fd1bb780a
Path: /downloads/Deluge
Total Size: 159.4 MiB
# of files: 1
Comment:
Status: OK
Tracker:


This means only 3rd line 28f47da2bd3ca0c033e7bac0793fe38fd1bb780a is can be recognized and start the download

Below are found in deluged.log

Code: Select all

[INFO    ] 05:50:20 torrentmanager:723 Saving the state at: /data/state/torrents.state
[INFO    ] 05:50:20 torrentmanager:531 Torrent 0000000000000000000000000000000000000000 added by user: localclient
[WARNING ] 05:50:20 torrentmanager:474 Error adding torrent: torrent already exists in session
[INFO    ] 05:50:20 torrentmanager:723 Saving the state at: /data/state/torrents.state
[INFO    ] 05:50:20 torrentmanager:531 Torrent 28f47da2bd3ca0c033e7bac0793fe38fd1bb780a added by user: localclient
[INFO    ] 05:50:55 torrentmanager:723 Saving the state at: /data/state/torrents.state
[INFO    ] 05:51:25 torrentmanager:765 Successfully loaded fastresume file: /data/state/torrents.fastresume
[INFO    ] 05:51:25 torrentmanager:811 Saving the fastresume at: /data/state/torrents.fastresume
Last edited by enri on Fri Feb 17, 2017 2:00 am, edited 1 time in total.

Cas
Top Bloke
Top Bloke
Posts: 3294
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: AutoAdd link error

Postby Cas » Wed Feb 15, 2017 10:46 am

Ok so it is a bug, the plugin can't handle magnets without a tracker or some other parameter missing. If you add an & at the end of the line if there is no tracker then it should work

enri
New User
New User
Posts: 7
Joined: Tue Feb 14, 2017 5:08 am
OS or Distro: docker

Re: AutoAdd link error

Postby enri » Wed Feb 15, 2017 6:00 pm

Thanks for confirming. Adding & at the end work.

About tracker, I further take out the unmodified link and made the following file
test15.magnet

Code: Select all

--removed--


This time, after the file is processed, the system returned a file called .magnet

Code: Select all

--removed--


The webgui do not have any item added. There is no added item in the log - only the following line:

Code: Select all

[INFO    ] 17:54:15 torrentmanager:723 Saving the state at: /data/state/torrents.state


I looked at the file torrents.state

Code: Select all

(ideluge.core.torrentmanager
TorrentManagerState
p1
(dp2
S'torrents'
p3
(lp4
sb.

Nothing changed, compare to torrents.state.bak

Any chance for this to get fixed?
Last edited by enri on Fri Feb 17, 2017 1:59 am, edited 1 time in total.

Cas
Top Bloke
Top Bloke
Posts: 3294
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: AutoAdd link error

Postby Cas » Wed Feb 15, 2017 11:38 pm

Ok so that is because &dn is an empty value.

I have fixed the issue in git and attached the updated plugin. Note if it's not working you may need to remove the existing plugin from Deluge package to resolve conflict.
Attachments
AutoAdd-1.5-py2.7.egg
(29.46 KiB) Downloaded 16 times

enri
New User
New User
Posts: 7
Joined: Tue Feb 14, 2017 5:08 am
OS or Distro: docker

Re: AutoAdd link error

Postby enri » Thu Feb 16, 2017 12:24 pm

-- content removed --
Last edited by enri on Fri Feb 17, 2017 1:58 am, edited 1 time in total.

Cas
Top Bloke
Top Bloke
Posts: 3294
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: AutoAdd link error

Postby Cas » Thu Feb 16, 2017 6:49 pm

Can you create a ticket for milestone 1.3.14 and I will remember look into it next week. Thanks

enri
New User
New User
Posts: 7
Joined: Tue Feb 14, 2017 5:08 am
OS or Distro: docker

Re: AutoAdd link error

Postby enri » Fri Feb 17, 2017 1:58 am



Return to “Support”

Who is online

Users browsing this forum: No registered users and 3 guests