Deluge 1.33 crashes when starting torrent from HTTPS tracker

Support for Deluge on Apple Mac OS
fancyclown
Member
Member
Posts: 25
Joined: Mon Oct 01, 2007 8:21 pm

Deluge 1.33 crashes when starting torrent from HTTPS tracker

Postby fancyclown » Sat Sep 10, 2011 10:43 pm

Hi
I just installed Deluge 1.33 through macports on a newly reinstalled snow leopard system.
It works fine except when I add a torrent from a tracker with HTTPS support..... then python crashes.
It worked on previous versions so what can be the problem that causes python to crash now?

I can't find any weird stuff in terminal after the crash but if anyone knows how to enable debugging please
tell me if it helps to solve the problem.

thanks

Cas
Top Bloke
Top Bloke
Posts: 3463
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Deluge 1.33 crashes when starting torrent from HTTPS tra

Postby Cas » Sat Sep 10, 2011 11:02 pm

You would need to use pdb to backtrace this crash but it suggests a libtorrent issue, what version are you using?

fancyclown
Member
Member
Posts: 25
Joined: Mon Oct 01, 2007 8:21 pm

Re: Deluge 1.33 crashes when starting torrent from HTTPS tra

Postby fancyclown » Sat Sep 10, 2011 11:45 pm

Cas wrote:You would need to use pdb to backtrace this crash but it suggests a libtorrent issue, what version are you using?

I use the latest one in macports: libtorrent-rasterbar 0.15.7

Is that the culprit huh? Should I try another version?

Apparently it got updated 4 days ago: https://trac.macports.org/browser/trunk ... r/Portfile

EDIT: I downgraded to libtorrent-rasterbar 0.15.6 but the problem is still there :(

carbncl
Leecher
Leecher
Posts: 92
Joined: Sun Nov 28, 2010 7:36 pm

Re: Deluge 1.33 crashes when starting torrent from HTTPS tra

Postby carbncl » Sun Sep 11, 2011 5:40 pm

Try to launch deluge with

Code: Select all

deluge-gtk-2.6 -L debug
that might bring some interesting logs.

fancyclown
Member
Member
Posts: 25
Joined: Mon Oct 01, 2007 8:21 pm

Re: Deluge 1.33 crashes when starting torrent from HTTPS tra

Postby fancyclown » Sun Sep 11, 2011 6:07 pm

carbncl wrote:Try to launch deluge with

Code: Select all

deluge-gtk-2.6 -L debug
that might bring some interesting logs.

This is what shows from when I click the add torrent button. Python crashes when i press ok to start the torrent. The gui stays up but I lose all the connections.

Code: Select all

[DEBUG   ] 19:51:38 toolbar:145 on_toolbutton_add_clicked
[DEBUG   ] 19:51:38 menubar:246 on_menuitem_addtorrent_activate
[DEBUG   ] 19:51:39 addtorrentdialog:539 _on_button_file_clicked
[DEBUG   ] 19:51:39 configmanager:111 Getting config 'gtkui.conf'
[DEBUG   ] 19:51:41 gtkui:272 sent: 7.6 Kb recv: 22.4 Kb
[DEBUG   ] 19:51:41 gtkui:280 sent rate: 0.1 KiB/s recv rate: 0.3 KiB/s
[DEBUG   ] 19:51:43 common:68 Attempting to open /Users/k/Downloads/--------.torrent.
[DEBUG   ] 19:51:47 addtorrentdialog:727 _on_button_add_clicked
[INFO    ] 19:51:47 client:228 Connection lost to daemon at 127.0.0.1:58846 reason: Connection to the other side was lost in a non-clean fashion.
[DEBUG   ] 19:51:47 component:244 Deregistering Component: GtkPlugin.AutoAdd
[INFO    ] 19:51:47 pluginmanagerbase:170 Plugin AutoAdd disabled..
[DEBUG   ] 19:51:47 component:244 Deregistering Component: GtkPlugin.WebUi
[INFO    ] 19:51:47 pluginmanagerbase:170 Plugin WebUi disabled..
[DEBUG   ] 19:51:47 gtkui:64 Blocklist GtkUI disable..
[DEBUG   ] 19:51:47 component:244 Deregistering Component: GtkPlugin.Blocklist
[INFO    ] 19:51:47 pluginmanagerbase:170 Plugin Blocklist disabled..
[DEBUG   ] 19:51:47 filtertreeview:319 nothing selected
[DEBUG   ] 19:51:51 gtkui:272 sent: 31.6 Kb recv: 24.0 Kb
[DEBUG   ] 19:51:51 gtkui:280 sent rate: 2.4 KiB/s recv rate: 0.2 KiB/s
[DEBUG   ] 19:52:01 gtkui:272 sent: 31.6 Kb recv: 24.0 Kb
[DEBUG   ] 19:52:01 gtkui:280 sent rate: 0.0 KiB/s recv rate: 0.0 KiB/s
[DEBUG   ] 19:52:10 menubar:259 on_menuitem_quit_activate
[DEBUG   ] 19:52:10 gtkui:249 gtkui shutting down..
[DEBUG   ] 19:52:10 listview:280 Saving ListView state file: torrentview.state
[DEBUG   ] 19:52:10 files_tab:266 Saving FilesTab state file: files_tab.state
[DEBUG   ] 19:52:10 peers_tab:197 Saving FilesTab state file: peers_tab.state
[DEBUG   ] 19:52:10 torrentdetails:406 Testing name: Status
[DEBUG   ] 19:52:10 torrentdetails:409 Set to Status 1
[DEBUG   ] 19:52:10 torrentdetails:406 Testing name: Details
[DEBUG   ] 19:52:10 torrentdetails:409 Set to Details 1
[DEBUG   ] 19:52:10 torrentdetails:406 Testing name: Files
[DEBUG   ] 19:52:10 torrentdetails:409 Set to Files 1
[DEBUG   ] 19:52:10 torrentdetails:406 Testing name: Peers
[DEBUG   ] 19:52:10 torrentdetails:409 Set to Peers 1
[DEBUG   ] 19:52:10 torrentdetails:406 Testing name: Options
[DEBUG   ] 19:52:10 torrentdetails:409 Set to Options 1
[DEBUG   ] 19:52:10 torrentdetails:416 Saving TorrentDetails state file: tabs.state
[DEBUG   ] 19:52:10 sidebar:67 hpaned.position: 170
[DEBUG   ] 19:52:10 config:423 Saving new config file /Users/k/.config/deluge/gtkui.conf.new
[DEBUG   ] 19:52:10 config:436 Backing up old config file to /Users/k/.config/deluge/gtkui.conf~
[DEBUG   ] 19:52:10 config:444 Moving new config file /Users/k/.config/deluge/gtkui.conf.new to /Users/k/.config/deluge/gtkui.conf..
[1]+  Bus error               deluged-2.6


Here is the entire debug from the start: pastebin

Again, Deluge works just fine with HTTP trackers.

fancyclown
Member
Member
Posts: 25
Joined: Mon Oct 01, 2007 8:21 pm

Re: Deluge 1.33 crashes when starting torrent from HTTPS tra

Postby fancyclown » Tue Sep 13, 2011 12:41 am

...
Last edited by fancyclown on Mon Sep 19, 2011 4:08 am, edited 1 time in total.

fancyclown
Member
Member
Posts: 25
Joined: Mon Oct 01, 2007 8:21 pm

Re: Deluge 1.33 crashes when starting torrent from HTTPS tra

Postby fancyclown » Mon Sep 19, 2011 4:07 am

Cas wrote:it suggests a libtorrent issue

You were right.
It is fixed in macports now by using libtorrent-rasterbar-devel: https://trac.macports.org/ticket/31277 :D

Shouldn't this be a problem for everyone who uses ssl trackers though, regardless of operating system?
Maybe I'm the only one who use HTTPS ;)

Cas
Top Bloke
Top Bloke
Posts: 3463
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Deluge 1.33 crashes when starting torrent from HTTPS tra

Postby Cas » Mon Sep 19, 2011 1:30 pm

I made a quick test with 0.15.6 on Linux but saw no issue. You would need to report this to libtorrent issue tracker so that it can be looked into.


Return to “Mac OS”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests