Deluge from MacPorts missing plugins?

Support for Deluge on Apple Mac OS
Gravey
New User
New User
Posts: 7
Joined: Thu Dec 24, 2009 3:48 am

Deluge from MacPorts missing plugins?

Postby Gravey » Tue Dec 29, 2009 8:58 am

I downloaded and installed Deluge using MacPorts on Mac OS 10.6.2 (Snow Leopard) by following the instructions here. It runs perfectly, but it doesn't appear that it came packaged with the default plugins (webui, label, etc.) I could not find these (specifically the label plugin) available for individual download on the Plugins page, so I downloaded a copy of the source from this site and compiled it, hoping to use the .egg files that resulted. Unfortunately, when I try to add these plugin .eggs to Deluge, it will not accept them. I'm able to locate them through the file browser, but clicking the "Open" button does nothing.

If someone could help me find a way to install these plugins, I'd appreciate it. Thanks in advance.

comedian
Member
Member
Posts: 29
Joined: Sat Nov 28, 2009 3:55 am

Re: Deluge from MacPorts missing plugins?

Postby comedian » Wed Dec 30, 2009 10:15 pm

I just copied the plugin egg files manually into the ~/.config/deluge/plugins directory, and then they worked fine. (Same problem on 10.5.8 actually).

Gravey
New User
New User
Posts: 7
Joined: Thu Dec 24, 2009 3:48 am

Re: Deluge from MacPorts missing plugins?

Postby Gravey » Thu Dec 31, 2009 8:19 am

I copied the plugins to that directory, but they still aren't showing up in the Addons section of Preferences. I've restarted both the client and daemon with no luck.

Edit: Never mind, got it. Thanks.


Return to “Mac OS”

Who is online

Users browsing this forum: No registered users and 1 guest