Duplicate Deluge processes running

Specific support for Deluge on Microsoft Windows OS
Luke90
New User
New User
Posts: 1
Joined: Mon Nov 13, 2017 5:02 pm
OS or Distro: Windows 10

Duplicate Deluge processes running

Postby Luke90 » Sat Nov 18, 2017 3:52 pm

I'm having a little trouble with Deluge 1.3.15 on Windows 10 Pro*. I was getting mysterious errors with added torrents disappearing from the client, removed torrents reappearing and in progress torrents saying that files are locked by another process.

Eventually, after lots of head scratching, I noticed that there were often two copies of the deluge process running which seems to be the source of the issues. Unfortunately, despite several attempts at troubleshooting, I haven't been able to pin down what events cause the duplicate process to start up. Sometimes they both seem to be running straight after a reboot, sometimes only one is running after booting up and the other starts up later for no apparent reason. I've got Deluge set to Autorun by dropping a link in the Start Menu's StartUp folder. (I don't think there's a duplicate start up entry in any of the myriad other places Windows uses because I've checked using Sysinternals Autoruns and also the duplicate process is often starting long after boot.)

It normally seems to be the case that one of the processes is using a little CPU and the other is idle. I'm completely stumped and the intermittent nature of the problem, or my lack of insight about how to replicate it, makes troubleshooting tricky. Does anyone have any suggestions about what might be causing the duplicate process to start up or how to prevent it happening?

Thanks in advance for any help or suggestions :)


*Currently on version 1703, build 15063.726, but this problem has been ongoing for a few months now so it predates recent updates.
Extensions I'm running, in case they're relevant: MyScheduler, WebUI, YaRSS2

Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 4 guests