Can't get to webUI with base URL enabled

Specific support for Deluge on Microsoft Windows OS
seanvree
Member
Member
Posts: 30
Joined: Tue Dec 27, 2016 1:42 pm
OS or Distro: windows

Can't get to webUI with base URL enabled

Postby seanvree » Sat May 13, 2017 1:24 am

Using Deluge 1.3.13
Windows 10

I"m starting the Delugeweb service with NSSM, it's been working fine, however, I'm trying to get the base function to work.

Right now, my arguments are : "-c c:\deluge -base /deluge/"

However, when I try to hit the webUI https://xx.xx.xx.xx:PORT (With no base) - then, the browser is just blank. If add the base https://xx.xx.xx.xx:PORT/DELUGE then I get no "No Such Resource No such child resource."

What am I doing wrong?

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can't get to webUI with base URL enabled

Postby Cas » Sat May 13, 2017 7:15 am

Base parameter is for reverse proxy, what server are you using?

http://dev.deluge-torrent.org/wiki/User ... verseProxy

seanvree
Member
Member
Posts: 30
Joined: Tue Dec 27, 2016 1:42 pm
OS or Distro: windows

Re: Can't get to webUI with base URL enabled

Postby seanvree » Sun May 14, 2017 12:21 pm

Cas wrote:Base parameter is for reverse proxy, what server are you using?

http://dev.deluge-torrent.org/wiki/User ... verseProxy


Yup, I'm familiar, I have plenty of other apps running reverse proxy. But I can't get this to work.

IIS on windows.

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can't get to webUI with base URL enabled

Postby Cas » Sun May 14, 2017 2:17 pm

seanvree wrote:IIS on windows.

The wiki page was created after testing with Apache and nginx. Have you translated those settings to IIS? If i recall correctly the base setting is an alternative for just the request header portion of configuration so the rest of the details still need applied to the IIS server.

It would be helpful if you can provide the IIS configuration. Also if you get it to work we can add it to the wiki.

seanvree
Member
Member
Posts: 30
Joined: Tue Dec 27, 2016 1:42 pm
OS or Distro: windows

Re: Can't get to webUI with base URL enabled

Postby seanvree » Mon May 15, 2017 7:01 am

Cas wrote:
seanvree wrote:IIS on windows.

The wiki page was created after testing with Apache and nginx. Have you translated those settings to IIS? If i recall correctly the base setting is an alternative for just the request header portion of configuration so the rest of the details still need applied to the IIS server.

It would be helpful if you can provide the IIS configuration. Also if you get it to work we can add it to the wiki.


Hey @cas - thanks for the help.

right now, the IIS server is irrelevant, as I can't even get to the WebUI on the computer without using the reverseproxy.

when I try to browse to

localhost:8112/deluge/

I get this in the browser:

"
No Such Resource

No such child resource"

Config looks like this:

{
"file": 1,
"format": 1
}{
"port": 8112,
"enabled_plugins": [],
"pwd_sha1": "7dd96fd18b08d7e93e4198a50bd1b847be57f1a4",
"theme": "gray",
"show_sidebar": true,
"sidebar_show_zero": false,
"pkey": "ssl/daemon.pkey",
"https": false,
"sessions": {
"b16891597b274625b9193eab056fa621": {
"login": "admin",
"expires": 1494834588.0,
"level": 10
}
},
"base": "/deluge/",
"interface": "localhost",
"pwd_salt": "9e012e9ac0d305676a3f8c908d9121f911eb26f0",
"show_session_speed": true,
"first_login": false,
"cert": "ssl/daemon.cert",
"session_timeout": 3600,
"default_daemon": "",
"sidebar_multiple_filters": true
}

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can't get to webUI with base URL enabled

Postby Cas » Mon May 15, 2017 8:57 am

No it won't work without your web server setup... It is only a fallback for reverse proxy use, which I already explained. There is a ticket with full details: http://dev.deluge-torrent.org/ticket/2677

seanvree
Member
Member
Posts: 30
Joined: Tue Dec 27, 2016 1:42 pm
OS or Distro: windows

Re: Can't get to webUI with base URL enabled

Postby seanvree » Tue May 16, 2017 4:31 am

Cas wrote:No it won't work without your web server setup... It is only a fallback for reverse proxy use, which I already explained. There is a ticket with full details: http://dev.deluge-torrent.org/ticket/2677


Okay, the problem is that the box that deluge is running isn't running my webserver.

So, let me ask you this. Can I run the WebUI on the box with IIS webserver, but the actual deluge-dameon on another box on the LAN?

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can't get to webUI with base URL enabled

Postby Cas » Tue May 16, 2017 9:41 am

seanvree wrote:Okay, the problem is that the box that deluge is running isn't running my webserver.

If it's on the same LAN I'm sure it would still work using it's ip address.


seanvree wrote:Can I run the WebUI on the box with IIS webserver, but the actual deluge-dameon on another box on the LAN?

Yes

seanvree
Member
Member
Posts: 30
Joined: Tue Dec 27, 2016 1:42 pm
OS or Distro: windows

Re: Can't get to webUI with base URL enabled

Postby seanvree » Thu May 18, 2017 8:39 am

@cas ,

I'm still having the same issue. Moved the WebUI to my webserver, and still getting the "no child resource"

I saw another dude having the same problem on NGIX. So I don't think it's just me:

https://www.reddit.com/r/Bittorrent/com ... work_with/

Also, here is my webserver config:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <outboundRules>
                <clear />
                <rule name="ReverseProxyOutboundDeluge" preCondition="ResponseIsHtml1">
                    <match filterByTags="A, Area, Base, Form, Frame, Head, IFrame, Img, Input, Link, Script" pattern="^http(s)?://192.168.1.20:8114/deluge/(.*)" />
                    <conditions logicalGrouping="MatchAll" trackAllCaptures="true" />
                    <action type="Rewrite" value="http{R:1}://seanvree.com/deluge/{R:2}" />
                </rule>
            </outboundRules>
            <rules>
                <clear />
                <rule name="ReverseProxyInboundDeluge" enabled="true" stopProcessing="true">
                    <match url="(.*)" />
                    <conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
                    <action type="Rewrite" url="http://192.168.1.20:8114/deluge/{R:1}" />
                </rule>
            </rules>
        </rewrite>
        <urlCompression doStaticCompression="false" doDynamicCompression="false" />
    </system.webServer>
</configuration>
Last edited by Cas on Thu May 18, 2017 9:43 am, edited 1 time in total.
Reason: Use code tags

Cas
Top Bloke
Top Bloke
Posts: 3442
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Can't get to webUI with base URL enabled

Postby Cas » Thu May 18, 2017 9:42 am

The nginx config on the wiki has been tested and works. That user is using a different config

Afraid I don't know how to configure IIS


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 5 guests