All torrents are gone after reboot

Specific support for Deluge on Microsoft Windows OS
FVGAZI
Member
Member
Posts: 10
Joined: Sun Jan 15, 2017 12:56 am
OS or Distro: Windows 10

All torrents are gone after reboot

Postby FVGAZI » Tue Mar 28, 2017 6:48 pm

All torrents are gone after reboot or if I restart deluged.
This started recently after a year of everything working fine.
I'm on 1.3.13 and would like to upgrade. Just want to fix this before I need to re-add 1,000 torrents for the 10th time manually.
I've checked the .state file and there's nothing in it.
Not sure what's caused this, but it's very frustrating :(

Cas
Top Bloke
Top Bloke
Posts: 3410
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: All torrents are gone after reboot

Postby Cas » Tue Mar 28, 2017 9:45 pm

Recent versions have fixes to prevent losing state data so it is surprising you are seeing that and it shouldn't happen restarting deluged but you need to provide more details along with debug logs if you can reproduce it.

Which file is empty or is the state folder empty?

FVGAZI
Member
Member
Posts: 10
Joined: Sun Jan 15, 2017 12:56 am
OS or Distro: Windows 10

Re: All torrents are gone after reboot

Postby FVGAZI » Tue Mar 28, 2017 9:51 pm

This is what I have in the torrents.state file...
(ideluge.core.torrentmanagerTorrentManagerStatep1(dp2S'torrents'p3(lp4sb.

I'd rather not reproduce this as it's a huge pain to re-add the torrents.

Is there anything I can look for that might cause this?

Cas
Top Bloke
Top Bloke
Posts: 3410
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: All torrents are gone after reboot

Postby Cas » Tue Mar 28, 2017 10:28 pm

Is there not a `torrents.state.bak` file?

How are you restarting deluged, perhaps with that many torrents is it being killed too quickly.

FVGAZI
Member
Member
Posts: 10
Joined: Sun Jan 15, 2017 12:56 am
OS or Distro: Windows 10

Re: All torrents are gone after reboot

Postby FVGAZI » Wed Mar 29, 2017 12:31 am

This is what's in the torrent.state.bak file...
(ideluge.core.torrentmanagerTorrentManagerStatep1(dp2S'torrents'p3(lp4sb.

Deluged is installed via nssm.
So I "nssm stop deluged" then "nssm start deluged"
I've only done that once to get rid of a torrent that wouldn't remove yesterday (another weird issue, but not my main concern).
There have been a couple of Windows updates recently and upon reboot all torrents are missing.
I guess I can just update deluge and cross my fingers.
Unless you have an idea what may have caused this and a fix?

I don't actually have 1,000 torrents seeding.
There are quite a lot though.

FVGAZI
Member
Member
Posts: 10
Joined: Sun Jan 15, 2017 12:56 am
OS or Distro: Windows 10

Re: All torrents are gone after reboot

Postby FVGAZI » Wed Mar 29, 2017 9:06 pm

I did the deluge update and was prompted to install "Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC Security Update".
A bit strange cause I have had that installed for a while before.
At any rate, all is working fine now. Restarted deluged and everything was as it should be.

krzaku
New User
New User
Posts: 2
Joined: Sat Apr 01, 2017 11:47 pm
OS or Distro: Unraid

Re: All torrents are gone after reboot

Postby krzaku » Sat Apr 01, 2017 11:55 pm

Same issue here. Same contents of torrent.state file as FVGAZI. I'm running Deluge 1.3.14 in Docker in Unraid. I remember there was something in the logs about Deluge not able to find torrent.state file, although the log has cleared since then so I cannot paste the exact line. Not sure what's that about, because the file is there, and is accessible (though I haven't checked the file before the Deluge was started after reboot, so I'm not sure of the contents). At the time I had 15 torrents added, half of which were paused, one was downloading and the rest was seeding. I'm doing daily backups so I was able to recover 14 of these torrents, but it's still annoying.

This issue happened once so far. More often, when a torrent hasn't finished downloading, I would get an error torrent status and would have to "force recheck" for the torrent to continue. I'm not sure if those two issues are connected.

krzaku
New User
New User
Posts: 2
Joined: Sat Apr 01, 2017 11:47 pm
OS or Distro: Unraid

Re: All torrents are gone after reboot

Postby krzaku » Mon May 29, 2017 12:50 am

Any news on this? I haven't experienced any more deleted torrents after docker restart, but I'm still experiencing torrent errors on incomplete torrents. I have the following line in the log, what does it mean?

Code: Select all

[ERROR   ] 02:00:48 torrentmanager:1147 on_alert_fastresume_rejected: Star.Trek.The.Next.Generation.S01-07.COMPLETE.1080p.BluRay.x264-MULTiGRP fast resume rejected: mismatching file timestamp

AlxT
New User
New User
Posts: 4
Joined: Sat May 27, 2017 8:35 am
OS or Distro: Windows Server 2012R

Re: All torrents are gone after reboot

Postby AlxT » Tue May 30, 2017 12:22 pm

Experience this once and it was solved as easily as restoring the :

Code: Select all

C:\Users\Username deluge is running under\AppData\Roaming\Deluge\state

No need to add the torrents manually :shock:


Return to “Windows OS”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest