Proxy settings not saving correctly

Support forum for Deluge on Microsoft Windows OS
Jaladhjin
New User
New User
Posts: 7
Joined: Mon Dec 12, 2016 8:14 am
OS or Distro: Windows 10

Proxy settings not saving correctly

Postby Jaladhjin » Fri Mar 24, 2017 2:54 am

so I enter in all the settings I'd like..

hit apply.. or ok.. or both.. doesn't matter..

then when I check them again only 1 is present the rest reset back to nothing :-(

http://imgur.com/a/FjcOX

Cas
Top Bloke
Top Bloke
Posts: 3296
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Proxy settings not saving correctly

Postby Cas » Fri Mar 24, 2017 7:06 pm

That is expected with recent change but proxy will apply to all in this instance. There is an open ticket that details the issue.

Hugoblank
New User
New User
Posts: 1
Joined: Wed Mar 29, 2017 1:20 pm
OS or Distro: Windows

Re: Proxy settings not saving correctly

Postby Hugoblank » Wed Mar 29, 2017 1:28 pm

For the record,
I'm having the same problem
Hugo

Cas
Top Bloke
Top Bloke
Posts: 3296
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: Proxy settings not saving correctly

Postby Cas » Wed Mar 29, 2017 3:15 pm

There is no issue, it's just a display conundrum. The single proxy (reflected by 'peer') now applies to all types. In order to fix a more serious issue with proxy not being set I thought it better to reset the other unused entries to none, however since this causes more confusion I shall instead mirror the peer setting across all of them.

http://dev.deluge-torrent.org/ticket/2991

dondraper2
New User
New User
Posts: 2
Joined: Sun Dec 11, 2016 6:18 pm
OS or Distro: WIN10PRO

PROXY support with 1.3.14 update

Postby dondraper2 » Wed Mar 29, 2017 5:09 pm

Windows 10
Deluge 1.3.14

Complete uninstall/reinstall and configure of Deluge on system. Only PEER settings are saved under PROXY (WebSeed/Tracker/DHT settings does save).
Just looking for confirmation WebSeed/Tracker/DHT settings are using PROXY please.

Thanks!

Jaladhjin
New User
New User
Posts: 7
Joined: Mon Dec 12, 2016 8:14 am
OS or Distro: Windows 10

Re: Proxy settings not saving correctly

Postby Jaladhjin » Thu Apr 06, 2017 5:42 am

Cas wrote:There is no issue, it's just a display conundrum. The single proxy (reflected by 'peer') now applies to all types. In order to fix a more serious issue with proxy not being set I thought it better to reset the other unused entries to none, however since this causes more confusion I shall instead mirror the peer setting across all of them.

http://dev.deluge-torrent.org/ticket/2991

You know what might cause even less confusion.. removing the others if they are not needed..

1 Proxy field.. 1 set of entries.. no one like me asking ever again :D
Last edited by Jaladhjin on Sat Apr 08, 2017 12:49 pm, edited 1 time in total.

ludwigmeyer
New User
New User
Posts: 3
Joined: Wed Apr 05, 2017 3:52 pm
OS or Distro: Ubuntu

Re: Proxy settings not saving correctly

Postby ludwigmeyer » Thu Apr 06, 2017 6:38 am

I'm using linux, but after updating to 1.3.14, I encountered the same issue. I found the references to this change but I'm still not sure the settings are being applied properly.

After setting the proxy, while a check my torrent IP came back correct, I was able to see by using tcpdump that my system was communicating direct with the peers listed in each active torrent. I was only after installing ltconfig and setting 'force_proxy' that all traffic began going only to my proxy ip.

And now I just found that after a restart of the deluged service, the force proxy setting reverted so i was back to peer to peer.


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 3 guests