deluge daemon bug (?): can't access "preferences"

Specific support for Deluge on Microsoft Windows OS
primeintuition
New User
New User
Posts: 3
Joined: Wed Nov 13, 2013 10:45 pm
OS or Distro: Windows 8.1

deluge daemon bug (?): can't access "preferences"

Postby primeintuition » Wed Nov 13, 2013 10:51 pm

Hello all,

I just installed Deluge v. 1.3.6 on a brand new computer (Windows 8.1). Immediately after installation, I am able to access "Preferences" without any issues. However, I want to use this application as a thin client... and when I set it up as such (unclick "enable" next to "classic mode" under "interface", enter server information, and connect) Deluge will no longer let me access "Preferences" (I click the menu option and nothing happens).

I have already (unsuccessfully) tried (1) restarting the server; (2) deleting appdata\deluge; (3) uninstalling and reinstalling deluge; (4) uninstalling deluge, deleting appdata\deluge, and reinstalling deluge. Same problem every time.

I'd love to hear your thoughts. Please let me know if I can provide any additional information or screenshots. Thanks.

EDIT: reversion to v. 1.3.5 also does not work.

Cas
Top Bloke
Top Bloke
Posts: 3463
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: deluge daemon bug (?): can't access "preferences"

Postby Cas » Thu Nov 14, 2013 9:49 am

Can you enable logging or run deluge from cmd to see if any errors occuring

primeintuition
New User
New User
Posts: 3
Joined: Wed Nov 13, 2013 10:45 pm
OS or Distro: Windows 8.1

Re: deluge daemon bug (?): can't access "preferences"

Postby primeintuition » Thu Nov 14, 2013 2:54 pm

There don't seem to be any errors occurring. This (capture 1) is what PuTTY looks like after I've restarted deluged and deluge-web on my server, then opened and run the thin client and unsuccessfully tried to access "Preferences."

There has been one further development: although I still can't access "Preferences" from the "Edit" menu like I'm used to, I've found that I can from the button on the toolbar, but only if I click that button several times in rapid succession -- this doesn't work if I only click it once. Bizarre. Once the "Preferences" menu does open, all options other than those under "Interface", "Options", and "Plugins" are greyed out. Not sure if this is normal for the thin client.
Attachments
Capture.PNG
capture 1
Capture.PNG (5.69 KiB) Viewed 5158 times

Cas
Top Bloke
Top Bloke
Posts: 3463
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: deluge daemon bug (?): can't access "preferences"

Postby Cas » Thu Nov 14, 2013 8:55 pm

Logs from thinclient not daemon...

You will not see any log output from daemon that way: http://dev.deluge-torrent.org/wiki/Faq# ... ingenabled

primeintuition
New User
New User
Posts: 3
Joined: Wed Nov 13, 2013 10:45 pm
OS or Distro: Windows 8.1

Re: deluge daemon bug (?): can't access "preferences"

Postby primeintuition » Thu Nov 14, 2013 10:26 pm

Cas,

I didn't know that -- thanks. What specifically should I input to CMD to get you the information you need? (Sorry, not incredibly experienced with torrent wrangling).

Cas
Top Bloke
Top Bloke
Posts: 3463
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: deluge daemon bug (?): can't access "preferences"

Postby Cas » Fri Nov 15, 2013 10:51 am

You can modify the shortcut or run from deluge program dir in a cmd window:

Code: Select all

deluge-gtk.exe -L debug -l C:\delugegtk.log


A screencast of the preferences working then not working rather than screenshot probably more useful in this case.

noco
New User
New User
Posts: 2
Joined: Sun Jan 05, 2014 6:48 pm
OS or Distro: WinXP

Re: deluge daemon bug (?): can't access "preferences"

Postby noco » Sun Jan 05, 2014 7:02 pm

Hi,

I am experiencing the same problem. I use Deluge 1.3.6 as a thin client (WinXP) to connect to a Deluge Daemon (Debian). At first I could access the preferences. But for quite some time it does not work anymore, the button just does nothing. Also the button often looks like it is activated (see screenshot), but I did not click it yet, also it not some hover effect as the mouse cursor did not touch the button yet.

Sometime when clicking the disk space symbol I can manage to open the preferences, but virtually all settings are greyed out / disabled.

Any help would be appreciated as I currently can only change preferences using the Webclient which is not optimal when lots of torrents are active.

Edit: The log basically shows this:
- started deluge
- closed connection manager
- clicked preferences button, preference dialog opens
- closed dialog
- opene connection manager, chose a daemon and connected to it
- clicked preferences button, nothing happened
- clicked the disk space symbol at the bottom multiple times, nothing happened

Edit2:
This does also seems to happen on MacOS as somebody on IRC said
Attachments
Kopie von delugegtk.log
debug file (censored)
(20.37 KiB) Downloaded 132 times
deluge.PNG
Button
deluge.PNG (13.28 KiB) Viewed 4891 times

Cas
Top Bloke
Top Bloke
Posts: 3463
Joined: Mon Dec 07, 2009 6:04 am
OS or Distro: Ubuntu 16.04
Location: Scotland

Re: deluge daemon bug (?): can't access "preferences"

Postby Cas » Tue Jan 07, 2014 12:34 am

What daemon version?

noco
New User
New User
Posts: 2
Joined: Sun Jan 05, 2014 6:48 pm
OS or Distro: WinXP

Re: deluge daemon bug (?): can't access "preferences"

Postby noco » Fri Jan 10, 2014 3:15 pm

deluged: 1.3.6
libtorrent: 0.15.10.0

lnxme
New User
New User
Posts: 1
Joined: Fri Sep 18, 2015 10:35 pm
OS or Distro: ubuntu

Re: deluge daemon bug (?): can't access "preferences"

Postby lnxme » Fri Sep 18, 2015 11:24 pm

Hello!

I am experiencing the same kind of behavior on ubuntu 14.04.3

Deluge 1.3.12 on both client and server.

using thin client and Deluge-gtk, preference button is unreseponsive, the rest of the UI is very very very slow to refresh.
It has always been slow, but lately, after my seedbox had suffered a couple of power outage, the GUI is useless.

Any ideas ?


Return to “Windows OS”

Who is online

Users browsing this forum: No registered users and 1 guest